Gentoo Wiki ArchivesGentoo Wiki

OSS4

Contents

About

This is a tutorial that helps installing Open Sound System, version 4 under Gentoo.

Overlay setup

Sync layman's overlay list:

layman -S

Add the OSSv4 layman overlay:

layman -a oss-overlay

Paludis

Note: Please someone that knows more about paludis confirm if this is really needed if we now have a layman overlay. (majeru)

Create the file /etc/paludis/repositories/oss.conf with the following content:

location=/var/paludis/repositories/oss
format=ebuild
sync= hg+http://hg.atheme.org/users/majeru/portage-overlay
master_repository=gentoo
names_cache=${location}/.cache/names
write_cache=/var/cache/paludis/metadata

Install

Note: before proceeding, you will need to add one of the following lines to /etc/make.conf, depending on the version of layman:

For layman versions prior to 1.2.0 use:

echo "source /usr/portage/local/layman/make.conf" >> /etc/make.conf

For layman versions 1.2.0 and later use:

echo "source /usr/local/portage/layman/make.conf" >> /etc/make.conf

The ebuilds have blockers for each other branch to force you to uninstall it first if you want to switch, so you may have only one of oss and oss-devel installed at a time, not both of them.

Warning: There are moments when the oss-devel branch fails, so be ready to switch when this happens.
Note: Driver names have changed between 4.0 and 4.1, so when changing a branch, make sure either to run "ossdetect" as root, or edit /usr/lib/oss/etc/installed_drivers by hand.

Make sure you have disabled the sound suport from the kernel before starting oss. With the new kernel just run ossdetect and soundon as root. Now you're good to go, don't forget to add soundon to a default runlevel.

Optional stuff

If you are using the unstable branch but you don't feel like being on the edge, you can mask the mercurial (VCS) ebuild:

echo "media-sound/oss-devel-9999" >> /etc/portage/package.mask

Keep your overlay up-to-date, by running from time to time

layman -s oss-overlay

then re-emerge OSS.

The USE flag flash will emerge libflashsupport (neccesary for Flash sound support). GStreamer has an OSS4 plugin (required for Gnome volume control), but there's no official ebuild yet. The overlay contains a gst-plugins-oss4 ebuild which can be used to build it. See also bug #232109.

Links

Retrieved from "http://www.gentoo-wiki.info/OSS4"

Last modified: Tue, 23 Sep 2008 02:17:00 +1000 Hits: 9,595

Created by NickStallman.net, Luxury Homes Australia
Real estate agents should list their apartments, townhouses and units in Australia.